Apache Flex 4.10 Released!

Today the Apache Flex Team has released the latest version to the Flex SDK, we are now at version 4.10.0!

Apache Flex 4.10.0 highlights include:

    • Support for latest versions of Flash Player and AIR runtimes. At the same time, we have made it easier for developers wanting to take advantage of the latest advances in the Flash runtimes by letting them choose the versions during installation. The Apache Flex SDK Installer now allows developers to select various combinations of the Flex SDK, Flash Player and AIR runtimes. All the settings and configurations are taken care of during the installation, so the developer can just start coding!
    • Improved support for older Flash Player versions. Enterprise environments have more stringent requirement in terms of upgrading Flash Player versions. Now, because of our improved backwards compatibility, those customers can safely upgrade to the latest version of the Flex SDK without having to force a Flash Player upgrade on their end users.
    • The new spark components ensure that SDK users can build functionalities quickly and in a more performant way. The need for handling these components in two different architecture styles (mx vs. spark) will be eliminated.
    • “Out of the box” support for Advanced Telemetry allowing developers to easily profile their application and improve performance using Adobe Scout.
    • Better localization for multiple languages. Flex 4.10.0 is better now when trying to make application for multiple countries and languages.
    • Better international support for dates in formatters, validators, and the DateField and DateChooser components.
    • Better for developer productivity – less Run Time Errors (RTEs) and workarounds required in 4.10.0
    • 480 dpi mobile resolution/skin support means that Flex SDK users can now target high resolution devices such as iOS Retina, etc.